Skip to content
Snippets Groups Projects
  • Roman Tsisyk's avatar
    876e401a
    Fix build system to properly support pluggable modules · 876e401a
    Roman Tsisyk authored
     * Install *.lua modules into ${DATADIR}/tarantool/1.5
        and *.so modules into ${LIBDIR}/tarantool/1.5
     * Fix default package.path and package.cpath
     * Install Lua headers to ${INCLUDE_DIR}/tarantool/1.5
     * Install config.h to ${INCLUDE_DIR}/tarantool/1.5
     * Add a new package - tarantool-dev (server development headers)
     * Use RPM Macroses in rpm.spec
     * Fix tarball generation for Debian
     * Use GNUInstallDirs.cmake to setup directories
    876e401a
    History
    Fix build system to properly support pluggable modules
    Roman Tsisyk authored
     * Install *.lua modules into ${DATADIR}/tarantool/1.5
        and *.so modules into ${LIBDIR}/tarantool/1.5
     * Fix default package.path and package.cpath
     * Install Lua headers to ${INCLUDE_DIR}/tarantool/1.5
     * Install config.h to ${INCLUDE_DIR}/tarantool/1.5
     * Add a new package - tarantool-dev (server development headers)
     * Use RPM Macroses in rpm.spec
     * Fix tarball generation for Debian
     * Use GNUInstallDirs.cmake to setup directories
control 5.74 KiB
Source: tarantool
Priority: optional
Maintainer: Dmitry E. Oboukhov <unera@debian.org>
Build-Depends: cdbs, debhelper (>= 8),
 cmake,
 libreadline-dev,
 python-yaml,
 python-daemon,
 python-pexpect,
 libncurses5-dev,
 libiberty-dev | binutils-dev,
 libmysqlclient-dev,
 libpq-dev
Section: database
Standards-Version: 3.9.5
Homepage: http://tarantool.org/
VCS-Browser: https://github.com/tarantool/tarantool
VCS-Git: git://github.com/tarantool/tarantool.git

Package: tarantool-common
Architecture: all
Priority: optional
Depends: ${misc:Depends}, adduser
Description: Tarantool in-memory database - common files
 Tarantool is an in-memory database and Lua application server.
 This package provides scripts to work with tarantool configuration
 and log files.

Package: tarantool
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Depends: ${shlibs:Depends}, ${misc:Depends}, tarantool-common
Conflicts: tarantool-dbg (<< 1.5.2)
Suggests: tarantool-dbg, tarantool-client, libdr-tarantool-perl
Description: In-memory database with Lua application server
 Tarantool is an in-memory database and Lua application server.
 Its key properties include:
 .
  * flexible data model
  * multiple index types: HASH, TREE, BITSET
  * optional persistence and strong data durability
  * log streaming replication
  * Lua functions, procedures, triggers, with rich access to database API,
    JSON support, inter-procedure and network communication libraries
  * a command line client supporting simple SQL and a native Lua console
 .
 This package provides Tarantool server.

Package: tarantool-dev
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Section: libdevel
Depends: ${shlibs:Depends}, ${misc:Depends},
 tarantool (= ${binary:Version}),
Description: Tarantool in-memory database - development headers
 Tarantool is an in-memory database and Lua application server.
 This package provides server headers needed to build pluggable modules.

Package: tarantool-modules
Conflicts: tarantool-plugins (<< 1.5.3)
Replaces: tarantool-plugins (<< 1.5.3)
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Depends: ${shlibs:Depends}, ${misc:Depends},
 tarantool (= ${binary:Version}),
 tarantool-sql-module,
 tarantool-postgresql-module,
 tarantool-mysql-module,
 tarantool-sophia-module
Description: Tarantool in-memory database - all plug-ins bundle
 Tarantool is an in-memory database and Lua application server.
 This package provides (or depends on) all Tarantool additional
 modules.

Package: tarantool-sql-module
Conflicts:
 tarantool-postgresql-plugin (<< 1.5.3),
 tarantool-mysql-plugin (<< 1.5.3)
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Depends: ${shlibs:Depends}, ${misc:Depends},
 tarantool (= ${binary:Version})
Description: Tarantool in-memory database - PostgreSQL connector
 Tarantool is an in-memory database and Lua application server.
 This package contains a connector to PostgreSQL database for
 Tarantool Lua stored procedures.

Package: tarantool-postgresql-module
Conflicts: tarantool-postgresql-plugin (<< 1.5.3)
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Depends: ${shlibs:Depends}, ${misc:Depends},
 tarantool-sql-module (= ${binary:Version}),
 tarantool (= ${binary:Version})
Description: Tarantool in-memory database - PostgreSQL connector
 Tarantool is an in-memory database and Lua application server.
 This package contains a connector to PostgreSQL database for
 Tarantool Lua stored procedures.

Package: tarantool-mysql-module
Conflicts: tarantool-mysql-plugin (<< 1.5.3)
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Depends: ${shlibs:Depends}, ${misc:Depends},
 tarantool-sql-module (= ${binary:Version}),
 tarantool (= ${binary:Version})
Description: Tarantool in-memory database - MySQL connector
 Tarantool is an in-memory database and Lua application server.
 This package contains a connector to MySQL database for Tarantool
 Lua stored procedures.

Package: tarantool-sophia-module
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Depends: ${shlibs:Depends}, ${misc:Depends},
 tarantool (= ${binary:Version})
Description: Tarantool in-memory database - sophia bindings
 Tarantool is an in-memory database and Lua application server.
 This package contains a bindings to the Sophia database for
 Tarantool Lua stored procedures.

Package: tarantool-client
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Depends: ${shlibs:Depends}, ${misc:Depends}
Suggests: tarantool-client-dbg
Description: Tarantool in-memory database - command line client
 Tarantool is an in-memory database and Lua application server.
 This package provides a command line client for Tarantool
 server with support of readline, command history, reader of 
 server binary logs and snapshot files.

Package: tarantool-client-dbg
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: extra
Section: debug
Depends: ${shlibs:Depends}, ${misc:Depends},
     tarantool-client (= ${binary:Version})
Description: Tarantool in-memory database - client debugging symbols
 Tarantool is an in-memory database and Lua application server.
 This package provides debugging symbols for the command line
 client.

Package: libtarantool-dev
Architecture: i386 amd64 kfreebsd-i386 kfreebsd-amd64 hurd-i386
Priority: optional
Section: libdevel
Depends: ${shlibs:Depends}, ${misc:Depends}
Conflicts:
 libtarantool1 (<< 1.5.2),
 libtarantoolnet1 (<< 1.5.2),
 libtarantoolsql1 (<< 1.5.2),
 libtarantoolrpl1 (<< 1.5.2)
Description: Tarantool in-memory database - development headers
 Tarantool is an in-memory database and Lua application server.
 This package provides headers for tarantool client.